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Introduction 
CourseGenie1 is a piece of software produced by Connected Learning2 that can be used 
to convert WORD documents to online learning materials. CourseGenie allows you to 
generate clean valid HTML from Microsoft WORD documents. It allows you to generate 
a course as an IMS3 zip file and then to bring it easily into WebCT. QMUC is piloting 
courseGenie for the next year (2005-2006), to determine how useful the staff find it for 
creating content for WebCT. 
The advantage of using courseGenie rather than using WORD’s inbuilt ‘Save as a web 
page’ option is that courseGenie outputs clean HTML. CourseGenie has also been 
designed to produce accessible materials that comply with SENDA4 legislation; the 
generated HTML complies with the WCAG5 priority levels 1, 2 and 3. 
CourseGenie works on the operating systems Windows 98, 2000 or XP. It works with 
WORD 2000, XP or 2003. CourseGenie is a PC only product and does not support 
Mac’s. 

CourseGenie documentation 
The following documentation, available from the Centre for Academic Practice (CAP), is 
to help you learn to use courseGenie: 

• Introduction to courseGenie 
• How to initialise courseGenie 
• Activity 1: Creating a WebCT content module using courseGenie 
• Activity 2: Adding extra features to a courseGenie generated course 
• Activity 3: Self test questions in courseGenie 
• Schemes in courseGenie [Advanced] 

You will also find it useful to refer to the ‘courseGenie Reference Manual’ this will have 
been installed as a PDF with courseGenie. You can open it from the 
Start Menu >All Programs > courseGenie > Documentation> CG Reference. 

The courseGenie interface 
CourseGenie works within the standard WORD interface, so it is familiar and easy for 
WORD users to master. The illustration below shows the courseGenie menu as it 
appears in WORD, and the two additional toolbars that are also available, CG Quest and 
CG Tags  

 
                                                 
1 See the courseGenie website for information: http://www.coursegenie.com/  
2 Connected Learning Ltd.: http://www.connectedlearning.co.uk/ 
3 IMS produce standard specifications for interoperable learning technology:  http://www.imsglobal.org/ 
4 Special Educational Needs and Disabilities Act 2001: http://www.hmso.gov.uk/acts/acts2001/20010010.htm  
5 Web Content Accessibility Guidelines 1.0 (WCAG) full guidelines available from: 
http://www.w3.org/TR/WCAG10/ 
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The first time you open courseGenie you will need to initialise it. This process is 
explained in the document ‘Initialising courseGenie’ 

Developing a course 
The following figure shows you the process that you go through to develop a WebCT 
content module from WORD documents.  

 
Figure 1 developing a course using courseGenie 

The development process is: 

• First gather together the course materials you want to use for your WebCT 
module. 

• If these materials are in different documents, combine them into one. 

• Apply courseGenie styles to the WORD document to break it up into separate 
pages. Add any additional resources such as images and media you would like to 
include. 

• Generate an IMS package in courseGenie 

• Import this as a content module in WebCT. 
 
The first activity “Creating a WebCT content module using courseGenie” will walk you 
through this process. 
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Course content in courseGenie 
CourseGenie allows you to simply convert WORD documents into interactive course 
materials. It will convert WORD content such as: 

• Tables 

• Lists 

• Hyperlinks 

• Images. 
It also allows you to generate additional content for online delivery: 

• Quizzes 

• Glossary 

• Media files. 
To ensure that the materials produced are accessible to students with disabilities, 
courseGenie includes an Accessibility Checker. If selected this will automatically check 
the code before generating the course, and will tell you which features need adjusting, 
for example you may need to: 

• Label data tables 

• Add alternative text for images 

• Add long descriptions for media content. 
The second activity “Adding extra features to a courseGenie generated course” will walk 
you through the inclusion of different types of content in a courseGenie generated 
course. There is an additional activity “Creating a self test in courseGenie” devoted to the 
creation of quizzes in courseGenie. 

Course presentation - schemes 
The presentation of the materials you output from courseGenie is controlled by selection 
of a scheme. To understand how this is done it is useful to look at how courseGenie 
works. CourseGenie generates valid HTML from a courseGenie marked up WORD 
document. The HTML contains all the structural elements of the document. The 
presentation is controlled by a Cascading Style Sheet (CSS). 

 

CourseGenie allows you to choose between style sheets, but instead of referring to a 
style sheet it calls this a Scheme. Use of schemes and how to develop new ones is 
included in the document ‘Schemes in courseGenie’ 
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How to initialise courseGenie 
The first time you open courseGenie on your PC at QMUC or at home you will need to 
initialise it. 

1. Before initialising courseGenie you need to check that your macro security 
settings in WORD are set to medium. Do this by opening WORD and going to the 
menu Tools > Macro > Security, the following dialog box will open, if it is not 
already selected, select Medium and then click OK. 

 
2. Now you are ready to initialise courseGenie, go to the 

Start menu > All Programs > courseGenie and open the  
Initialise courseGenie WORD document 
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3. This will open WORD and the following dialog box will open. 
Click Enable Macros. 

 
4. CourseGenie will ask you to locate you courseGenie instillation folder. The typical 

path will be C: drive > Program Files > courseGenie 

 
 

5. The following dialog will then open, after you click OK WORD will shut down and 
the instillation is complete. 
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Starting to use courseGenie 
First open WORD, and switch on courseGenie from 
Tools > courseGenie > Start courseGenie: 

 

You will then see that the courseGenie Menu is available from the top WORD menu. 
Two courseGenie toolbars are also available, CG Quest and CG Tags. If these are not 
available you can open them from the main menu View > Toolbars. 
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module using courseGenie 
 
 
 
 
Estimated time 1 hour 

Prerequisites A basic knowledge of WORD 

A basic knowledge of uploading files in WebCT 

Files requires Successful study.doc 

extra.doc 

diary.gif 

Overview This exercise uses courseGenie to convert a standard Microsoft WORD 
document to a content module in WebCT 
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In this activity you will use courseGenie to develop a WebCT content module from a 
Microsoft WORD document. 

Starting to use courseGenie 
1. First open the document “Successful study.doc” in WORD. This contains a 

sample of a course which you will be converting using courseGenie. 

 
2. Next make sure that you have opened courseGenie. Once courseGenie has been 

installed on your computer you can open it from the top menu Tools > 
courseGenie > Start courseGenie 
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3. Once courseGenie is open you can see that you now have a courseGenie menu 
on the main WORD Menu. You also have two extra courseGenie (CG) toolbars, 
and a range of CG styles available. If the toolbars are not available you can open 
them from the main menu View > Toolbars. 

 

Chuncking the WORD document 
CourseGenie with generate HTML pages from the WORD document. To do this you 
first need to apply some styles to the document. 

4. Highlight the first heading in the document “Successful study at a distance” and 
apply the cgSectionTitle style. This will be the first section heading. 
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Note: cgSectionTitle will generate the section level heading, the cgPageTitle pages will 
be nested beneath them, you can have multiple sections, for example: 
1 First main Heading (cgSectionTitle) 

1.1 Sub Heading (cgPageTitle) 
1.2 Sub heading (cgPageTitle) 

2 Second main Heading (cgSectionTitle) 
2.1 Sub Heading (cgPageTitle) 
2.2 Sub heading (cgPageTitle) 

 
5. Next highlight the second heading in the document “Preparing to study” and apply 

the cgPageTitle style. Each time you apply the heading you will create a new 
page. Add this to all the other headings in the document (headings are in bold 
type). 
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Adding an Image 
6. On the second page you will see a picture of a diary. In HTML this picture will 

need a text alternative for students who are visually impaired. You can add this 
from the Format Picture dialog box. Double click on the picture to open the dialog 
box and select the Web tab. Here you add the alternative text “Drawing of an 
open diary”. When generated, this will be in an “alt attribute” in the HTML. 

 
You are now ready to generate this course and see what it looks like in WebCT. 
7. First go the courseGenie menu and select Settings, this will open the following 

window. On the General tab Make sure that you have checked the box “Copy 
media files to output folder” 
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Preparing to generate a course 
8. On the Navigation tab make sure that you have unchecked the boxes “Generate 

Index Page”, “Show Navigation buttons on each HTML page”, and “Show 
Navigation column on each HTML page”, leave the other settings as they 
appear below. 

 
 
9. On the Content tab, select the radio button “WebCT IMS package” then click 

‘OK’. 
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10. You are now ready to generate the course. Go to the courseGenie menu and 
click on Generate Course: 

 
11. You will then be asked to navigate to the folder where you would like to save the 

output, select a folder and click ‘OK’. The following window opens as the course is 
being generated. Once you see the following message the course has been 
generated. Click on Close to close the window. Now close down WORD. 

 

Importing the IMS package into WebCT 
You will now open up WebCT and import this content module. 

12. Login to a module in WebCT where you have Designer access. 
13. In your WebCT area, go to Control Panel then open Manage Files. Under 

Options: Files on the right hand side, select Upload. You should now navigate to 
the folder you selected and find the file Successful study_IMSWCT.zip which 
courseGenie has generated and upload it. 

14.  In WebCT go back to the Control Panel > Manage Module and select 
Import Content. Check the radio button “Import a content package” this screen 
is illustrated below. Next enter the title for your content module “Successful 
Study”. Select the file to import “Successful study_IMSWCT.zip”, and check the 
boxes to select links on the Module Menu and Organiser Page (Home Page). 
Finally click on Import. 
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You will see the following screen showing that the import has been successful, click on 
Done.  

 
If you go back into the File Manager, you will see that when WebCT created the content 
module it unzipped the file you imported. This  will be inside My Files > ims_import 
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Note: If you import a second ims zip file, it will create a new folder called ims_import_1, 
this happens for each additional zip file that you import, so even if you reimport the same 
zip file, the content is not overwritten. 

You can then go back to the Home page, you will see the new icon you have created, 
click on it and browse through the imported content. Your first page should look similar to 
the one below: Remember that if you want the students to see the new content, you will 
need to open the Control Panel in WebCT and click “Update student view”. 

 

Below is an example of the page “Managing your time” here you can see that the image 
has been brought across and that the alternative text is included in the “alt tag”. 
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You have now completed the first part of this exercise. In the next section we will 
consider how to edit the content you have created, and then look at adding further 
materials to the content module. 

Editing content that has been developed in courseGenie 
After a course has been generated its content is standard HTML and can be edited in 
several ways. 

1. The easiest way to make small changes is through the interface in WebCT. 
2. You can also download the file you need to edit, and, if you are familiar with 

HTML, make changes in any text editor (Notepad, WordPad) or by using any web 
development software (Dreamweaver, FrontPage), before re-uploading the file. 

3.  For significant changes you can go back to the original WORD document, make 
the changes and then regenerate a new IMS content package in courseGenie. 
You can then use this to replace the one that is already in WebCT. 

Editing a page through the WebCT interface 
1. Go into your content module in the Designer view. 

 
2. Click on the name of the file in which you wish to make the changes. 
3. The following screen will open. Under File Option click on Edit File. 
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4. If you are comfortable with HTML, you can edit the file content inside the scrolling 
window. If you would prefer to view it without the tags, click on the HTML editor. 

 
If you open the HTML editor you will see the interface below. Make you changes and 
then click on Save: 

 
5. Next click Update Student View, your change is now complete. 
You may wish to experiment with editing your files in WebCT. 
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Adding extra content to a module that has been developed in 
courseGenie 
Once an IMS content package has been brought into WebCT you can add additional 
pages to it in the standard WebCT way, by uploading a single file. If you want the extra 
page to look like those you have already generated in courseGenie, you can use 
courseGenie to create a single HTML page, which can then be uploaded into WebCT. 
The next part of the exercise will show you how to bring in an additional page to the 
content module that you imported into WebCT in the last part of the exercise. 

1. Open “extra.doc” in WORD. Highlight the heading “Studying a module” and apply 
the courseGenie Style cgPageTitle. 

 
2. Open the courseGenie menu and select Settings. Open the Content tab and 

select the radio button Normal HTML pages.  
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3. Still in the courseGenie Settings dialog, go to the General tab, and write “extra” 

under the Page root box. Then click OK. As you are adding an additional page, 
you need to make sure that the generated page name is different from that 
generated for the first content module, so as not to over write a file. 

 
4. Go to the courseGenie menu in WORD and click on Generate Course. 
5. Locate the folder that has been generated by courseGenie and find the single 

HTML page that you want to upload. 

 

Note: When courseGenie generates the HTML pages for you it numbers them 
consecutively from _01.htm. You can set a root name for the pages in the courseGenie 
Settings window under the General tab, in the Page root box. For example if you set 
the Page root to extra the generated pages would be called: 
extra_01.htm 
extra_02.htm 
extra_03.htm 
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6. In WebCT go to the Control Panel open Manage Files and upload the new file 
“extra_01.htm” into the content folder you have created, this should be called 
something like: ims_import. 

7. Go into the content module you have created in WebCT, under the Actions menu 
on the right select Add files. 

 
8. Browse to the file you are adding “_01.htm” and click the button Add. 

You will now see that the extra page has been added to the end of the content module. 
You can move it to where ever you want to put it using the Organise options. 
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The new page should look like the rest of the modules. 

 
Your new page should look similar to the one above: Remember that if you want the 
students to see the new page you have added, you will need to open the Control Panel 
in WebCT and click “Update student view”. 

 
Well Done! You have now completed Exercise 1 
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Exercise 2: Adding extra features to a 
courseGenie generated course 
 
 
 
 
Estimated time 1 hour 

Prerequisites A basic knowledge of WORD 

A basic knowledge of courseGenie 

A basic knowledge of uploading files in WebCT 

Files required cgfeatures.doc 

Example.xls 

Example.ppt 

NewhavenLighthouse.jpg 

Newhaven.jpg 

Overview This exercise explores the additional features of courseGenie: 

• Tables and lists 

• Hyperlinks and linked files 

• Images 

• Media 
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In this exercise you will explore further features of courseGenie. CourseGenie generates 
clean HTML output from standard WORD content, including tables, lists and hyperlinks. 
In this exercise you will explore these features, and view the output in HTML, which you 
can then import into your modules. You will also look at ways in which courseGenie 
allows you to add additional media content. 
Open WORD and make sure courseGenie is open, you can open it from the top menu 
bar by going to Tools > courseGenie > Start courseGenie. 

Chunking the document 
Open the WORD document provided “cgfeatures.doc”. This document contains a list of 
the titles of the separate pages (in bold text).  

1. Chunk the document into the separate pages, first highlight the first heading 
“features of courseGenie”” by applying the “cgSectionTitle” style. 

2. Next chunk the rest of the document into the separate pages by applying the 
“cgPageTitle” style. 

You can now test the document to see how it looks, this time rather than generating the 
course as an IMS content package, as we did in Exercise 1, we will generate it as HTML 
pages and set courseGenie to generate an index and menu pages. This allows us to test 
the pages outside of WebCT. When you are ready to bring the module into WebCT it is 
advisable not to generate the navigation, as this would duplicate the navigation in 
WebCT and would be confusing for students. 
Go to the main WORD menu bar courseGenie > Settings, this will open the window 
illustrated below, open the Navigation tab and check the following boxes: 

Generate Index Page 
Show Navigation buttons on each HTML page 
Show Navigation column on each HTML page. 
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Next open the Content tab and select Generate content as Normal HTML pages.  
Click OK 

 
Now you will generate the course: go to the main WORD menu bar  
courseGenie > Generate Course. A dialog box will open asking you to choose where to 
save the output folder, you should navigate to the place where you would like to put it 
and click OK. The generation process will now start. 
When the following dialog box opens, check Preview in Browser and click Close. 

 
The generated content will then open in a browser window. You can see that 
courseGenie has generated several HTML pages from the marked up WORD document. 



Adding extra features to a courseGenie generated course. 

Susie Beasley, Alex Chapman & Susi Peacock, Spring 2005 31
 

Tables and Lists 
We will now add content to the first section “Tables and lists”. Close the browser and 
return to the WORD document. 

1. Under the heading “Tables and lists” insert a table: 
Do this in the standard WORD way, from the main WORD menu bar 
 Table > Insert > Table. 

NOTE: courseGenie cannot process tables with merged cells. If you do try to generate a 
course including a table with merged cells you will see the following error message, you 
will need to remove the merged cells before the course will generate. 

 

Lists are very simple to create and are added into the WORD document in the standard 
way.  

2. To test this, add a bulleted list, and a numbered list to the page. 
When you generate the page you will see that courseGenie has converted the table and 
lists into HTML. Your page should know look something like the one illustrated below. 
You can see that nested lists are also converted. 
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Hyperlinks and linked files 
We will now add content to the section “Hyperlinks and linked files”. Close the browser 
and return to the WORD document. 

1. Add a hyperlink to the Queen Margaret University College website 
(http://www.qmuc.ac.uk/) in your WORD document. Do this in the standard 
WORD way: 
Add the text “Queen Margaret University College website” to the document, 
highlight it and right click on the mouse to bring up the menu, select Hyperlink.  
In the hyperlink dialog box, under address, add http://www.qmuc.ac.uk/. 

Generate the course with courseGenie, you can now open up the page and check that 
the hyperlink works. 
You can also link to other Microsoft files; we will now link to the sample EXCEL file you 
have been given “Example.xls”. This is done in the standard WORD way as described 
below. 

2. Add the text “Link to spreadsheet”, highlight this and then right click to bring up 
the menu and select HyperLink. In the Insert Hyperlink dialog box, (illustrated 
below) select link to: “Existing File or Web Page” and under address add 
Example.xls. 

 
3. Repeat this process to link to the sample PowerPoint file “Example.ppt”. 
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4. Before generating the course you will need to ensure that the files you are 
including will be copied across to the output folder. Do this from the main menu 
courseGenie > Settings, this will open the window illustrated below. Check the 
box “Copy media files to the output folder”. 

 
Now generate the course and check that the links work. 

Images 
We will now add content to the section “Images”. Close the browser and return to the 
WORD document. 

1. Add the image provided “NewhavenLighthouse.jpg”, use the standard WORD 
method 
Insert > Picture > From File and navigate to the picture. 

Note: When an image is included in an HTML page it must be given a text alternative. 
The alternative text would be displayed onscreen if the image was not downloaded, for 
example if the browser was set not to display images, or a text only browser such as 
Lynx was being used. This alternative would also be read to a person who is unable to 
see the image and was accessing the site using a screen reader. Adding “alt” tags is in 
an important accessibility requirement, and one that QMUC staff must adhere to. 

2. You can add the alt text in courseGenie by right clicking on the image to bring up 
the Format Picture window. Click into the Web tab and add the Alternative text 
“Photograph of Newhaven lighthouse”. Don’t forget to click OK. 
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Some images require a fuller description, for example diagrams or graphs. You can 
provide this in the same window.  

3. To see what this would look like insert the picture “Newhaven.jpg” and add the 
following text in the Alternative text window, include the line break as shown 
below: 

Newhaven Harbour 
An atmospheric photograph of Newhaven Harbour, taken on a misty afternoon. 
The bright sunshine is reflected on the water, this is in sharp contrast to the dark 
silhouettes of the buildings. 

 

Note: courseGenie will generate a long description whenever you include more than one 
paragraph in the alternative text dialog box. In this case “Newhaven Harbour” will be the 
alt text and the paragraph after will be included in the separate page generated for the 
long description. 

Now generate the course. The image should now appear with a [D] beside it, when this 
is clicked it links to a new page which will open with the description. 
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Drawn images in WORD 

CourseGenie does not recognise images which have been drawn inside WORD, using 
the standard Draw tools (example below). 

 

To include these drawn images in your course they must be converted to embedded 
images. First select all elements of the image by holding down the ctrl key and clicking 
on each part of the drawing. Next from the Edit menu select Cut, move the cursor out of 
the drawing window. Now from the Edit menu select Paste Special and select Picture 
(GIF). The picture will now be included in the courseGenie generated output. Please 
note that you can no longer edit the drawing after converting it. 

 

You may like to try this out before moving on to the next section. 
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Media 
We will now add content to the first section “Media”. Close the browser and return to the 
WORD document. 

1. Do this from the courseGenie Menu > Media to open the following window. 

 
From here you can add Flash, Real Audio, realVideo, Windows media or QuickTime 
files. 
CourseGenie provided several files for you to experiment with, you can find them on your 
computer, where they will have been installed with courseGenie, typically in: 
C: Program Files > courseGenie > Media Samples. 

2. You are going to add a flash file so first check the radio button Flash. 
3. Under the File option in the Media window, browse to the sample Flash file 

“alpha.swf” which has been provided by courseGenie. 
4. Under the display options, check the box beside Loop, then click OK. Your 

document should look something like this: 
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5. Generate your course and the output should look something like this: 

 
 

 
Well Done! You have now completed Exercise 2 
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Exercise 3: Self test questions in 
courseGenie 
 
 
 
 
Estimated time 1 hour 

Files required SelfTestSource.doc 
CGSelfTest.doc 
menu.gif 

Overview This exercise explores the self test questions that can be created in 
courseGenie. 
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In this exercise you will explore the courseGenie question editor. CourseGenie 
generates self test questions which can be embedded in the content, and give immediate 
feedback to the students. Self test questions are not scored or tracked, if you require this 
you will need to use the quiz tool in WebCT. The Centre for Academic Practice (CAP) 
can assist you in developing tracked quizzes. CourseGenie self tests are recommended 
for use as part of the learning process. 
CourseGenie offers 15 question types these are discussed in detail in the ‘courseGenie 
Reference Manual’ this will have been installed as a PDF with course genie. You can 
open it from the Start Menu >All Programs > courseGenie > CG Reference. 
For this exercise you have been given two WORD documents: 

• “SelfTestSource.doc” – The text you will need to make the self test. 
• “CGSelfTest.doc” – The finished self test, marked up in courseGenie 

You will work from the SelfTestSource.doc, but may find it useful to refer to the finished 
document. 

Making a question 
You can add a question into a WORD document, using the Question Palette. 

 
To open the Question Palette: go to the WORD menu bar View > Toolbars and select 
> CG Questions. You can add questions where ever you think they are appropriate, so 
you can dot them through the course, or group questions together as a test. 
 

Note: To change the question view 
From the Question Palette, go to Question, and you can toggle the view between 
Compact and extended view. 

 
To edit a question 
First put the cursor inside the grey area of the question you want to edit,  next from the 
Question Palette, go to Question, and you can toggle the view between Compact and 
extended view. 
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In this exercise we will make a test consisting of 6 questions on a single HTML page. 
First we will prepare the document and go through the first question in detail. On the next 
page is a brief description of the question types available in courseGenie.  

1. Open the document SelfTestSource.doc 
2. Highlight the heading “Self Test Quiz” and apply the style cgPageTitle. 
3. The first question we will add is a simple true/false question; this is a variation on 

a multiple question. First put your cursor into the document, where you want to 
insert the question. 
Open the Question Palette > select Multi Choice > True/False. 
This open up the following dialog box: 

 

4. Cut and paste the question into each text box, from the WORD document 
provided. When you have finished click OK. In the WORD document the question 
should look something like this (Extended view) 

 

5. Go to the courseGenie menu >Generate course, and take a look at the generated 
question. 
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When you are happy with the completed question, you can delete the table with the 
question text. 
 

Note: The questions developed in courseGenie are self test questions. They are 
designed to let the student evaluate their own learning. The feedback you provide for the 
questions is as valuable as the question itself, because this can help guide the student 
towards gaps in their understanding. Every question type in courseGenie has the option 
to include feedback. 

Question types 
CourseGenie offers 5 basic question types, each of which come in several varieties. In 
the WORD document SelfTestSource.doc, you will find the source for an example of 
each type. The list below summarises the features of each type of questions. For more in 
depth information refer to the courseGenie Reference guide. 

1. Multi Choice: Basic Multiple choice question, with only one correct answer. 
• True/False [Example 1]: Offers ‘correct’ or ‘incorrect’ feedback. 
• Multi Choice 1: Offers ‘correct’ or ‘incorrect’ feedback. 
• Multi Choice 2: Different feedback for each possible answer. 

2. Multi Response:  Similar to a multiple choice question, but with multiple correct 
answers. 

• Multi Response 1: One feedback irrespective of which boxes are checked. 
• Multi Response 2: Separate feedback for each checkbox, score displayed. 
• Multi Response 3 [Example 2]: ‘Correct’ or ‘incorrect’ feedback for whole 

question. 
3. Text Entry: A short answer question to be input from the keyboard. 

• Text Entry 1: Answer not evaluated, one feedback displayed irrespective of 
answer. 

• Text Entry 2: Users answer displayed with correct answer for user to 
compare. Answer not evaluated 

• Text Entry 3 [Example 3]: Evaluates text that user inputs and gives ‘correct’ 
or ‘incorrect’ feedback. 

4. Matching: Question asks you to match a set of answers with a set of match items  
• Matching 1: Not evaluated, correct answer in feedback 
• Matching 2 [Example 4]: Evaluated, with ‘correct’ and ‘incorrect’ feedback. 

5. Gap Fill: Question requires learner to fill in gaps in a text. 
• Gap Fill 1: Text fill boxes. Not evaluated, correct answer supplied in 

feedback. 
• Gap Fill 2: Text fill boxes Evaluated and a score given, with ‘correct’ and 

‘incorrect’ feedback. 
• Gap Fill 3:  Drop down boxes. Not evaluated, correct answer supplied in 

feedback. 
• Gap Fill 4 [Example 5] Drop down boxes. Evaluated and a score given, 

with ‘correct’ and ‘incorrect’ feedback. 
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For the next part of this exercise you should reopen “SelfTestSource.doc” and make the 
example questions 2 to 5. Do this by cutting and pasting from the WORD document 
using the courseGenie Question Palette, as described for Example question 1. You can 
refer to the document “CGSelfTest.doc” which shows finished versions of the questions if 
you need any help. 
All of the information you will need to create each question is provided in a table in 
“SelfTestSource.doc”. 

1. Example 2 is an example of a multiple response question; place your cursor in the 
WORD document from the Question palette select the type 
Multi Response > Multi Response 3.  
This question is constructed in a very similar way to Example 1. The only 
difference is that as there are multiple correct answers, you need to mark the 
correct answers in the check boxes. Cut and paste all the content provided into 
the question and click OK. 

 
When this question is generated the output should look like this: 
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2. Example 3 is an example of a text entry question; place your cursor in the WORD 

document from the Question palette select the type  
Text Entry > Text Entry 3.  
This type of question requires a short answer that is to be input from the 
keyboard. This question type evaluates whether the input is the same as the 
answer supplied, and provided feedback if the input is ‘correct’ or ‘incorrect’. It 
allows you to include multiple correct answers, if there is more than one 
acceptable answer, in the example given there are 4 correct variations of the 
answer. 
Cut and paste all the content provided into the question and click OK. 

 

When this question is generated the output should look like this: 
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3. Example 4 is an example of a matching question; place your cursor in the WORD 

document and from the Question palette select the type 
Matching > Matching 2.  
This type of question gives a list of questions with a list of possible answers which 
you can select from a drop down list. In the table for the example question the 
answer is followed by the correct match. 
To make it more difficult for the student to guess you can mix up the order when 
you create the question, a check box beside the answer allows you to link it to the 
correct matching pair. Cut and paste all the content provided into the question and 
click OK. 

 

 

When this question is generated the output should look like this: 
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4. Example 5 is an example of a fill in the gap question; place your cursor in the 

WORD document and from the Question palette select the type  
Gap Fill > Gap Fill 4.  
This type of question displays a passage of text, in place of selected words is a 
drop down box, from this the student must select the answer. 
Example 5 gives the text for the passage, cut and paste this into the answer box: 

 

Then highlight the word that is to be used as a gap, the first one is “CourseGenie” 
and click Gap. The word will now appear in square brackets, [CourseGenie]. 
Repeat this for each of the gap words. Cut and paste all the provided given into 
the question and click OK. 

 

When this question is generated the output should look like this: 
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Adding images 
You can add images into courseGenie’s self test questions. These can be included in the 
question, answers or feedback. The final question [Example 6] in the WORD document 
“SelfTestSource.doc”, will include an image, this file has been provided for you and is 
called “menu.gif”.  

1. Open the WORD document “SelfTestSource.doc” 

2. Put your cursor into the document where you want to create the question. Open 
the courseGenie Question palette. Select the question type Multi Choice 2. 

 

3. Copy and paste the question text into the courseGenie 
Question builder.  
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4. When you are finished click OK. You will see the question marked up in the text, if 
you are in Extended view it will look like the picture below (if you do not see this, 
change the view to extended) 

 
5. Put your cursor into the grey question area, just below the closing tag of the 

question </text>.  
Next go to the WORD menu Insert > Picture > From File and browse to the 
location of the image “menu.gif”. The question should know look like: 
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6. Go to the courseGenie menu and Generate Course. The finished question 
should look something like this:  

 
 

Note: Adding an image/or images should be the last thing you do to a question. Because 
the images are inserted into the code, if you then re-edit the question from the Question 
Palette, the link to the image is lost. 

 
Well Done! You have now completed Exercise 3 
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Course presentation - schemes 
You can alter the presentation of the materials you output from courseGenie using 
schemes. To understand how this is done it is useful to look at how courseGenie works. 
CourseGenie generates valid HTML from a marked up WORD document. The HTML 
contains all the structural elements of the document. The presentation is controlled by a 
Cascading Style Sheet (CSS). 

 

CourseGenie allows you to choose between style sheets, but instead of referring to a 
style sheet calls this a Scheme. If you open up the courseGenie menu at the top of the 
screen and select Settings the dialog box illustrated below will open. Next select the 
General tab, you will see Scheme and a drop down box with several options. 
CourseGenie offers you several inbuilt options: Standard, High Contrast, Red or Green. 
On the illustration below you can also see a couple of non-standard Schemes: ‘QMUC’ 
and ‘Plain’ that have been developed.  

 
This document describes how to create a new scheme for courseGenie. 

Adding new design schemes 
The design schemes menu (pictured above) is controlled by the file schemes.dat, which 
is located in the courseGenie Config directory. This file takes the following form: 

Standard, scheme1 
High Contrast, scheme2 
Red, scheme3 
Green, scheme4 
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The first name in each pair is the scheme name that will appear in the drop down menu, 
the second is the name of the directory containing the scheme data. These directories 
are subdirectories of the Config directory, and contain the style sheet file cg.css and a 
buttons subdirectory containing the graphic images for each button state. Note that you 
would not usually use the buttons when generating content for WebCT as WebCT 
generates its own navigation tools. 

1. Navigate to the schemes in your copy of courseGenie. This will depend on where 
you have installed courseGenie, but will typically be reached by going:  
My Computer > C:Drive > Program Files > courseGenie > Config 

 

2. Copy the directory of the scheme that you would like to base your new scheme 
on, for example, scheme1 back into the folder and rename it, for example 
scheme6. 

3. Edit the file schemes.dat (located in the Config directory) to add a new entry, this 
will be the name of the new scheme (as you want it to appear on the menu drop 
down) followed by the new directory name. 

4. Go into the new directory you have created and open the cg.css this is a 
standard Cascading Style Sheet and allows you to change the colours and font 
properties for all areas of the courseGenie output. 

When courseGenie is next restarted, the new scheme will be shown in the 
dropdown menu. 
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CourseGenie FAQ 
1. Can I use courseGenie and Outlook? 
At the moment courseGenie and Outlook do have some conflicts, and so it is 
advisable to close Outlook before opening courseGenie. 
2. Can I use courseGenie and Acrobat Professional? 
At the moment courseGenie and Acrobat Professional do have some conflicts, and 
so it is advisable to close Acrobat Professional before opening courseGenie. This 
does not effect Acrobat Reader. 
3. When I add a long description to an image, it appears on other images on 

the page as well? 
This, unfortunately, is a bug in courseGenie. To get round it you will need to add a 
long description text to every image on the page. 
4. CourseGenie will not generate any output and is giving the error message 

“End tag ‘newpage’ does not match the start tag ‘cell’.” 
You will probably find that you have put a cgSectionTitle in a table, remove this and 
try again. 
5. I have tried to put an image or bullet point inside a cgPanelText area, but 

when I generate the course they are not there? 
You can’t include images or bullet points in a cgPanelText area. Images included 
nearby will often appear to float over the area. 
6. I have used merged cells in a table, courseGenie has given me an error 

message when I tried to generate the course, why is this? 
CourseGenie does not support merged cells, you will need to remove them and 
redesign your table. 
7. How can I make the images align to the right side of the page? 
In WORD you right click the image, this will open the following window. Click on the 
Layout tab, Select the Wrapping style Tight and Horizontal Alignment right. 

 



CourseGenie FAQ 

Susie Beasley, Alex Chapman & Susi Peacock, Spring 2005 54
 

8. I have downloaded a page from a content module that I made using 
courseGenie. When I open it in Dreamweaver/FrontPage, it does not look the 
same, why is this? 

CourseGenie links the pages to its own style sheet, cg.css. To view the files correctly 
outside of WebCT, you will also need to download the stylesheet. You will find it 
inside the ims_import folder that was created when you unzipped the content module. 
9. Help, I have uploaded the ims content package exactly as the instructions 

told me to, but the students can’t see the content? 
You should go to the control panel in WebCT and click “update the student view”, this 
needs to be done whenever you add or amend a content module. 
10. I have included lots of diagrams in my WORD document, when I try to 

generate the course I get an error message (see below) saying that course 
contains drawn images and that these cannot be converted by courseGenie. 
When I open the generated course the images are missing. How can I add 
these? 

 
CourseGenie does not recognise images which have been drawn inside WORD, 
using the standard Draw tools (example below) 

 

To include these drawn images in your course they must be converted to 
embedded images. First select all elements of the image by holding down the ctrl 
key and clicking on each part of the drawing. Next from the Edit menu select Cut, 
move the cursor out of the drawing window. Now from the Edit menu select 
Paste Special and select Picture (GIF). The picture will now be included in the 
courseGenie generated output. Please note that you can no longer edit the 
drawing after converting it. 

 

 


